Top > Diary > 2012-07-10

現在起きている問題について

どうしよ~~~~

マスターアップは先月の 21 日に一通り終わり、29 日にパッチも出し、いわゆるすごい忙しい時期というのは過ぎ去ったのだけれど、それからというもの、ずっとサーバをいろいろいじくっているのね。TAMA Networks は Pukiwiki Plus! というシステムで組まれている。現在の amatsukami.jp サーバの PHP バージョンは 5.2.14。PHP はすでに 5.4 になってしまった。
なので PHP をバージョンアップしたかったのだが、これが PHP5.4 にすると Pukiwiki Plus! が動かない。原因はざっとソースを眺めた感じ、いくつかあるんだけど、そのうちの一つが Pukiwiki で使われている関数とまったく同じ関数が PHP5.4 からついたこと。これがぶつかってしまってそもそも動かない。
ただこれはおそらくだけれど、関数をオーバーライドしてしまえば行けると思う。

ってやってみたんだけど、それでもなんだかうまく動かない。
困ったなぁ……。

で、マスターが終わったらそもそも TAMA Networks を Wordpress という CMS に移行しようと考えていて、その準備は既に整えてあった。問題はこの古い Pukiwiki の記事をどうするかと言うこと。基本的には Pukiwiki の方も同時に動かしておいて、古い記事はそっちを見てくれってやろうと思ってたのね。でも PHP5.4 にしちゃうと Pukiwiki は動かない。
となると、古い記事も Wordpress に移さなければならない。
これは非常に面倒くさい!! コンバータを作ればいいとかそういう問題じゃない。というのもそもそも Wordpress は設定項目が多すぎて、単純にコンバートしただけじゃ(というかムリヤリ DB にストアすることになると思うんだけど)、あまり意味がない。

う~~ん、まいったなぁ……どうしよう。
というところで、とりあえず日記が止まっているのです(爆)。
ほんとどうしようかなぁ……。

Error: Flash Player Cannot Installed.

#article


リロード   新規 下位ページ作成 編集 凍結 差分 添付 コピー 名前変更   ホーム 一覧 検索 最終更新 バックアップ リンク元   ヘルプ   最終更新のRSS
Last-modified: Fri, 26 Oct 2012 07:43:01 JST (1762d)